BundyPlus Now Mobile App GPS tagging issue (iOS Only)

Incident Report for BundyPlus

Resolved

BundyPlus Now services have been fully restored and are operating normally. We appreciate your patience during this time and apologise for any inconvenience caused. If you continue to experience any issues, please contact our support team.
Posted Jul 17, 2025 - 12:35 AEST

Monitoring

Our team has implemented a fix to address the recent issue, and the updated version is now live on the Apple App Store. We're actively monitoring the results to ensure everything is running smoothly. We sincerely appreciate your patience and understanding throughout this process. If you notice any lingering issues, please don’t hesitate to contact our support team.
Posted Jul 17, 2025 - 10:43 AEST

Update

The latest update remains under review by the Apple App Store. Once approved, it will be available for download. We appreciate your continued patience!
Posted Jul 17, 2025 - 09:52 AEST

Update

The latest update is still under review by the Apple App Store. Once approved, it will be available for download. We appreciate your continued patience and support while we work to get everything back on track!
Posted Jul 17, 2025 - 09:10 AEST

Update

We've submitted a fix, and it's currently under review by the Apple App Store. Thanks for your patience!
Posted Jul 17, 2025 - 08:32 AEST

Update

We are continuing to work on a fix for this issue.
Posted Jul 17, 2025 - 07:40 AEST

Identified

Our team has identified the cause of the issue affecting BundyPlus Now mobile App. We are currently applying a fix. We estimate that services will be restored by 8:30AM AEST.
Thank you for your patience as we work to resolve this issue.
Posted Jul 17, 2025 - 07:38 AEST

Investigating

We are currently experiencing an issue affecting the BundyPlus Now mobile app, specifically GPS tagging, which prevents employee clocking in some instances (iOS only). Our team is investigating the cause and working to resolve it as quickly as possible. We apologise for any inconvenience caused and will provide updates as soon as we have more information.
Posted Jul 17, 2025 - 07:35 AEST
This incident affected: my.BundyPlus.com.au (Possum 01 Enterprise, Possum 02 Enterprise, Possum 03 Enterprise, Possum 04 Enterprise, APIv2).